Loyalty-Beta

Affected components
Loyalty API
Updates

Write-up published

Read it here

Resolved

Resolved — Monitoring. We identified intermittent 502 responses from Payment-Gateway-X as the root cause of Loyalty checkout failures. Traffic was routed to a fallback gateway and a configuration rollback was applied; error rate dropped from ~10% → ~0.8% and checkout success has returned to near-normal levels. We’re continuing to monitor metrics for 30 minutes to validate stability — if metrics remain stable we will mark this incident fully resolved.

Tue, Sep 9, 2025, 10:39 AM

Investigating

We’re investigating an issue affecting Loyalty checkout where some customers experience failed payments or timeouts due to intermittent 502 errors from our payment gateway. Engineers are routing traffic to a fallback gateway and working on a permanent fix — next update in 15 minutes.

Tue, Sep 9, 2025, 10:39 AM
Powered by

Loyalty-Beta